ドラッグ&ドロップでの文字列移動/コピー(Ver8.91対応版)
目次基本的なキー/マウス操作− ドラッグ&ドロップでの文字列移動/コピー
 マウスやキーボードで範囲選択したら、その範囲選択した部分をマウスでドラッグすることができます。
 ドラッグすると、マウスカーソルの下に縦長の棒が表示されます。それを好きな位置に移動してマウスボタンを離すと、そこに範囲選択した文字列が移動します。
 離すときにCtrlキーも押していると、移動ではなくてコピーになります。
 ドラッグしている途中でやっぱり止めたい場合は、Escキーを押せばいいです。
 秀丸エディタのウィンドウ同士で、ウィンドウをまたがって文字列をドラッグ&ドロップすることも出来ます。その場合はCtrlキーを押さえなくてもコピーの動作となります。移動させるには、この場合はShiftキーを押さえながらドロップする形になります。

 ドラッグ&ドロップを使えるようにするには、[その他]→[動作環境]→[編集]→[高度な編集2]の「ドラッグ&ドロップ編集」がONになっている必要があります。逆に言うと、ドラッグ&ドロップ編集させたくない場合はここのオプションをOFFにしてください。

マウス右ボタンによるドラッグ&ドロップ

 設定にもよりますが、秀丸エディタのV8.20から、マウス右ボタンでもドラッグ&ドロップ出来るようになました。マウス右ボタンでドラッグ&ドロップした場合は、左ボタンの場合と違ってドロップした後に「移動するか/コピーするか」のメニューが出てきて、そこで移動/コピーを選択することが出来ます。

 マウス右ボタンによるドラッグ&ドロップが出来るためには、[その他]→[動作環境]→[編集]→[高度な編集2]の「ドラッグ&ドロップ編集」がONになっていて、さらに[その他]→[動作環境]→[表示/操作]→[カーソル操作]の「右ボタンのキー割り当てはボタンアップ時に行う」がONになっている必要があります。